พอดีเจอปัญหา Error “An SDK Target must be specified.” ในขณะที่เริ่มต้นสร้าง Android Project บน Eclipse ตามรูปด้านล่างครับ

Eclipse Android error - An SDK Target must be specified

ซึ่ง Error ดังกล่าวเกิดจาก Eclipes ไม่สามารถหาโฟลเดอร์ Install ของ SDK เจอ ดังนั้นเราต้องไปกำหนดให้ Eclipes รู้เสียก่อนดังนี้

เข้าไปที่เมนู Window -> Preferences. จะมีหน้าต่างใหม่ขึ้นมา ให้เลือก Android (ด้านซ้าย) ให้กด Browse เพื่อเลือก โฟลเดอร์ SDK ที่เรา Download ดูรูปด้านล่างประกอบ

Select Android SDK

หรือลองดูขั้นตอนการติดตั้งแบบเริ่มต้นที่นี่ เริ่มต้นเขียนโปรแกรมบน Android ต้องติดตั้งอะไรบ้าง?

ที่มา : http://flummox-engineering.blogspot.com/2011/04/eclipse-android-error-sdk-target-must.html

Author:

(ตั้ม) ศิริชัย ธีรภัทรสกุล เป็นเว็บโปรแกรมเมอร์ และบล็อกเกอร์ สนใจเรื่องการพัฒนาตัวเอง หลงใหลการถ่ายรูป เวลาว่างมักชอบอ่านหนังสือ ปัจจุบันผมยังรับพัฒนาเว็บไซต์ หากสนใจสามารถติดต่อสอบถามได้ครับ